As has already been announced and is public knowledge version 1.0 of the TLS protocol is not secure and in fact neither is version 1.1. Therefore, it is necessary to disable it on servers that must comply with PCI requirements.

If you are on a computer with Mac operating system and using Apple Mail and trying to connect to our mail server you will get the message "Can not connect to the mail server". The first thing we recommend is check the email client configurations information is correct, but if the configuration is correct that means the TLS version supported by your Mac operating system or your Apple Mail versions do not support the versions allowed on our servers.

If you are using OS X Sierra or 10.12 or higher (High Sierra 10.13 has the best support in fact), you should not have problems as they probably have support for the latest TLS versions, but in those versions of the operating system where you are using an old  Apple Mail version (for example V 9.3) most probably you can have issues.

In the case you have an old operating system or a version of an email client like old Apple Mail, you have two options:

1- Update the operating system on the device and the version of the email program.

2- In the case you are unable to update the operating system in your device, use an email client with TLS 1.2 support, like Thunderbird, etc.

To request help with these updates, please contact Apple support.

Was this answer helpful? 1 Users Found This Useful (2 Votes)