Remoción de soporte PHP 5.x a partir de Junio

15 Apr 2019

Como ya sabes, siempre estamos comprometidos con la alta calidad y la seguridad en nuestros servicios. En esta oportunidad, estamos anunciando que eliminaremos las versiones antiguas de PHP 5.x de la disponibilidad en nuestros servidores de Alojamiento Compartido cPanel a partir de junio de 2019.

¿Por qué?
PHP 5.x ya no tienen soporte de sus desarrolladores hace varios años. Las versiones de PHP 5.x en nuestros servidores son versiones seguras, parcheadas por Cloudlinux en forma privada. Sin embargo, aunque se ejecuten versiones antiguas protegidas y parcheadas, el problema generalmente no es el propio php sino el script/programa desarrollado para dichas versiones. Tienen agujeros de seguridad, a veces están con falencias en el código y son un alto riesgo para el entorno de alojamiento compartido.

¿Puedo cambiar a una nueva versión de PHP?
Sí, esta opción ya está disponible en tu cPanel -> Sección Seleccionar versión de PHP. Puedes ver el artículo paso a paso de nuestra Base de conocimientos en https://secure.plusplushosting.net/knowledgebase/1090/Seleccionando-su-version-de-PHP-en-su-cPanel.html

¿Funcionará mi script con alguna de las nuevas versiones?
Esto es algo que tienes que comprobar. La mayoría de los scripts de código abierto populares como Wordpress, Joomla, etc. ya están trabajando con esas nuevas versiones. Simplemente puedes cambiar la versión de PHP como se describe anteriormente y probar. También, asegúrate de tener la última versión del script. Por ejemplo, si está ejecutando una versión anterior de Joomla o Wordpress, lo más probable es que no funcione, primero debes actualizar a la última versión de Joomla, Wordpress, etc.

Si tienes un script desarrollado a medida y personalizado, es posible que debas verificarlo con tu desarrollador.

¿Mi script no funciona con las últimas versiones de PHP, pueden arreglarlo ustedes?
Ten en cuenta que nuestro soporte del servicio de alojamiento web se limita a mantener los servicios funcionando, mantenemos toda la infraestructura de los servidores actualizados y te brindamos un entorno y tecnología seguros y modernos, pero esto no incluye soporte de mantenimiento o corrección de códigos en los programas que tengas instalados en tu cuenta. Puedes contactarnos si necesita el soporte adicional y presupuestaremos específicamente para cada caso. Si tienes scripts de terceros como Wordpress, Magento, etc., cada uno tiene su propio canal de soporte (foros)... la mayoría de las veces, si actualizas a la última versión del script, no tendrás problemas... la mayoría de los mismos ya soporta las últimas versiones de PHP.